viernes, 5 de abril de 2013

PSeInt: Factorial de un número

El siguiente pseudocodigo calcula el factorial de un número ingresado por el usuario:

Proceso factorial
    
    acum<-1;

    Escribir "Digite un numero para calcular su factorial";

    Leer num;

    Para i<-1 Hasta num Con Paso 1 Hacer

        acum<-acum*i;

    FinPara
    
    Escribir "El factorial de ",num," es ",acum;

FinProceso

Se crea un variable acumuladora para almacenar las multiplicaciones.

5 comentarios:

  1. acum es una variable acumuladora que almacena las multiplicaciones: ejemplo:

    factorial de 3:
    1x2x3=6

    No necesariamente se tiene que llamar acum.

    ResponderEliminar
  2. Como seria el calculo del factorial utilizando "Mientras/para/repetir" con sumas remplazando la multiplicación?

    ResponderEliminar
  3. Este comentario ha sido eliminado por el autor.

    ResponderEliminar